Android 14 डेवलपर्स के लिए अपडेट की गई API आवश्यकताओं के अनुपालन में पुराने ऐप्स को ब्लॉक करने के लिए

48
Android 14 फोन के शेयर मेनू को बदल सकता है: इसका क्या मतलब है
Advertisement

 

इस परिवर्तन के साथ, उपयोगकर्ता विशिष्ट एपीके फ़ाइलों को साइडलोड नहीं कर पाएंगे।

एंड्रॉइड 14 की अपडेटेड एपीआई आवश्यकताएं जल्द ही पुराने एप्लिकेशन की स्थापना को पूरी तरह से प्रतिबंधित कर देंगी।

डेवलपर्स अब Google Play Store में पोस्ट किए गए नए ऐप्स के लिए Android 12 या बाद के संस्करण को लक्षित करने के लिए बाध्य हैं, और Android 14 से शुरू होकर, Android के पुराने संस्करणों को लक्षित करने वाले ऐप्स मैलवेयर चिंताओं को कम करने के लिए पूरी तरह से प्रतिबंधित होंगे।

हिसार के नारनौंद में युवक को सुए से गोदा: 2 साल पहले हुआ था मामूली झगड़ा; हालत गंभीर, 2 हमलावरों पर FIR

9to5Google की एक रिपोर्ट के अनुसार, अब तक न्यूनतम एपीआई स्तर की आवश्यकताएं केवल Google Play Store पर सबमिट किए गए ऐप्स पर लागू होती थीं। डेवलपर अभी भी पुराने Android संस्करणों के लिए ऐप बना सकते हैं और उपयोगकर्ताओं को साइडलोडिंग के माध्यम से मैन्युअल रूप से एपीके फ़ाइल स्थापित कर सकते हैं। हालाँकि, Android 14 की अपडेटेड API आवश्यकताएँ हाल ही में एक कोड अपडेट के अनुसार पुराने एप्लिकेशन की स्थापना को पूरी तरह से प्रतिबंधित कर देंगी।

इस परिवर्तन के साथ, उपयोगकर्ता विशिष्ट एपीके फ़ाइलों को साइडलोड नहीं कर पाएंगे और ऐप स्टोर उन विशिष्ट ऐप्स को इंस्टॉल नहीं कर पाएंगे।

Apple अफवाह वाले iPad प्रो मॉडल के लिए क्रैक-फ्री फोल्डेबल डिस्प्ले के लिए पेटेंट लेता है

रिपोर्ट में आगे कहा गया है कि एंड्रॉइड 14 डिवाइस शुरू में केवल उन ऐप्स को ब्लॉक करेंगे जो “पुराने एंड्रॉइड वर्जन” के लिए हैं, लेकिन बाद में इसे एंड्रॉइड 6.0 मार्शमैलो को शामिल करने के लिए बढ़ाया जाएगा। लेकिन यह संभव है कि प्रत्येक डिवाइस निर्माता के लिए कटऑफ चुनने के लिए स्वतंत्र होगा। पुराने ऐप्स या यहां तक ​​कि इसे सक्षम करना है या नहीं।

 

“यदि न्यूनतम इंस्टॉल करने योग्य एसडीके संस्करण प्रवर्तन सक्षम है, तो आवश्यकता से कम लक्ष्य एसडीके संस्करण का उपयोग करके ऐप्स की स्थापना को रोकें। Google ने एक डेवलपर पोस्ट में कहा कि इससे सुरक्षा और गोपनीयता में सुधार करने में मदद मिलती है क्योंकि नए एपीआई व्यवहार के प्रवर्तन से बचने के लिए मैलवेयर पुराने एसडीके संस्करणों को लक्षित कर सकता है। Google का प्राथमिक लक्ष्य Android चलाने वाले उपकरणों (पुराने उपकरणों सहित) को संक्रमित करने वाले मैलवेयर पर कार्रवाई शुरू करने की संभावना है।

.

.

Advertisement